2005-06-02

Hotmail rich composer user script

I don't use Hotmail a lot. But when I do, I use Firefox most of the time. I think Microsoft did a bad job on the Mozilla version of the composer. Yesterday I've had it and decided to write a Hotmail rich composer (0.1.2) user script for Greasemonkey which replaces the plain textarea.

0.1.2

This version now works with Firefox 1.5 and Greasemonkey 0.6.4.

0.1.1

  • Fixed: Send message by clicking icon left of 'Send' now works.
  • Fixed: Safe draft now works.

0.1

Initial version.

21 comments:

Franco said...

you can't reply to emails with this user script

Jasper said...

@Franco. I've noticed that sending mail using the send icon didn't work. Microsoft uses a link and a onclick on the table cell to trigger the send function. I had only fixed the link in version 0.1, in 0.1.1 I have removed the link and use the onclick in the table cell. Please let my know if this doesn't fix your problem.

Leo Katz said...

The link to your script is broken... It seems your host (members.lycos.nl) is down. I get timeout errors all the time. Can you check it, please?
TIA

Leo Katz said...

Now it's working. Thanks for this great script, Jasper! It works like a charm...

Adrian said...

Great script, but still has a few glitches. From the composer view, I click on the 'Mail' tab at the top and go back to the Inbox view. Now, if you click the 'New' toolbar item to start a new message, the composer view has the text entry box with the rich composer toolbar (with the about link) repeated below the text entry area and the cursor is not focused in the edit box. When you try to type (I have begin finding when you begin typing turned on), the find toolbar at the bottom of the browser comes on instead of characters going to the text entry area.

If, from the inbox view, instead of choosing 'New', I choose 'Mail Message' from the drop down under this toolbar item, the rich composer shows up correctly, but every once in a while you can't set focus in the text area and as soon as you type, Firefox tries to find text.

Jasper said...

I haven't done much work on this script after I initially wrote it since I don't use Hotmail that much. I'll see if I can make some improvements some time.

Jasper said...

My guess is that the can't-set-focus problem is a Firefox bug. I've seen behavior with the Midas (Firefox) editor on other products as well. I hope that it will be fixed in Firefox 1.5. Testing it with the beta version of Firefox 1.5 is not such a good idea since the beta in combination with the current 0.6 beta of Greasemonkey are no good.

Katy said...

I am a hotmail user and when I use Mozilla Firefox I have discovered that I do not have the option of using the rich text editor for e-mails. However, when I use regular internet explorer, I have the toolbar and the option to turn it on or off. Is there anyway I can get this feature on Firefox?

Andrew Mantell said...

Hi,

Just to let you know, this script stops your signature from appearing when you compose new mails...

Andy

Mozillaphile said...

It doesn't seem to work with FF1.5. It completely grays out the text compose area - both for new messages and reply messages. I hope you could make some time to fix it.

Thanks.

Ruben said...

I have re-installed it several times in the last two weeks and still doesn't work with Firefox for composing and replying to emails because the body of the email is completely grey-out. It does work with IE though.

Jasper said...

@Ruben: it still doesn't work because it hasn't been fixed yet. This script will be fixed but other scripts have higher priority.

ziad said...

did someone find a way to fix the "grey-out" thing in the body of the mail composer ?

Anonymous said...

script works fine for except when i try to add attachments to an email. does anyone else have a problem when doing this ?

Zach said...

For some reason, I think it removed my signature. It's ususally inserted before I even start to type my message. Even though I made a new one, it still isn't adding it to my message. Is anyone else haveing this problem?

Qifan Xi said...

Hi,

I modified the 0.1.2 version of your script to add a drop-down menu for forecolor and have been distributing it to some of my friends. I hope this isn't a problem.

If anyone else is interested (and if you're okay with it), I can post a link to the modified version of your script.

Anonymous said...

Argh! I just composed a long e-mail reply and when I added attachments the whole thing disappeared. Ah well maybe if you get some time you can fix it thanks for the effort anyway.

Jasper said...

Can you reproduce this problem?

Anonymous said...

hey, um..how do i install this script to work with Firefox 1.5.0.6.? Can someone email me the instructions please?

my email: fatal_shadows31@hotmail.com

Anonymous said...

hey guys it me again, don't bother email me d instructions, i got it...thanks alot.

Mozbius said...

Hmmm after some use I've noticed even though it's quite a nice script it doesn't seem to work when you attach files... Can this be fixed?